Jump to content

Can't See any Liveries on Vatsim, Only white planes.

Jimmy Stigsjoo

Recommended Posts

Jimmy Stigsjoo

Hello all,

Another silly question for what is starting to a bigger issue for me:

When im flying around on Vatsim, i don't see any liveries on any airplanes at all, however it IS displaying the correct airplane model. But the skins are just 100% White, or should i say, no texture at all.

( In the beginning, every plane showed a standard White model regardless of the type people actually used, but that was fixed . Livery issue remain )

Now, i have googled around like a maniac, and while i find alot of threads , info and solutions around this problem, it all seem to be tied to the model matching and not the livery matching, so i have tried what they suggest, but without success.

What i have and what i have done:

* Using Vpilot
* Vpilot has matchmaking enabled
* I run Vpilot as Admin
* Liveries display properly for myself
* Liveries display properly on AI Aircraft when enabled to test it ( AI Disabled usually )
* I Fly the PMDG, so i have access to all the liveries thru it, but only have SAS models installed.

With reference to the latest Point, i thought that it would be obvious that i need to install ALL the liveries for my computer to be able to render them on other peoples Aircrafts, and i havnt tried that, but i HAVE looked at people who use the PMDG with the same SAS Skin as i do, and it still doesnt display the Livery on them - Only on me.

So, i really want to fix this.. Mainly because of immersion, but also " Follow Company 777 to A3 " instructions is getting quite difficult on crowded Airports ...  But also, most importantly i need to have this fixed Before my ATC training start, so i can actually see the planes too.

Any suggestions, tips or tricks or stuff that i can try?

Thank you.

// Jimmy

Link to post
Share on other sites
Jouka Ahponen

Hello Jimmy,

I think you are somehow confusing model matching and livery matching to be separate things. Model matching means that aircraft and the livery will show correctly.

Do you have AI model package downloaded with multiple liveries for each aircraft? Such packages are WoAI, vpilotAI, SPAI etc. If so, have you generated a model matching ruleset for all your liveries so vpilot is able to find those models and liveries from the correct folder and link it with correct aircraft on sim.

I am not going to go fully in detail how model matching works but this is the simple form of instructions that should work for everyone.

1. Download and install one of the AI model packages you desire (Just know, IVAO MTL cannot be used on VATSIM anymore). You can find lots of help for this from google but I think vpilotAI is one of the easiest to install.
2. After you have all the models installed on you simulator, generate a model matching ruleset for the models you are using. To do this download VMR generator (http://www.lekseecon.nl/VMRGenerator.html) and follow the instructions. It should create a file AI Matching Rules Generated.vmr. Move that file to your ...\Documents\vPilot Files\vPilot Rules and name it whatever you want (for example vpilotair.vmr)
3. Go to vpilot. Navigate to Settings -> Model Matching. Check that you have correct simulator showing at "Configured for Simulator". After that go to Custom Rules tab and add the new .vmr file you generated. Press Apply and OK. Restart Flight simulator and vpilot and you should now see vpilot configuring multiple models for your simulator which means everything is good.

If you don't see models being configured after you restart your simulator, most likely your simulator is not identifying them. In that case, depending on your simulator, navigate to simobjects.cfg (P3D 3.4 or newer) or fsx.cfg (FSX and P3D 3.3 and older) and check that you have an Entry for your models made. If not create it yourself like this:

Path=SimObjects\vPilotAI (may be different depending on what models you installed and where they are located)

Hopefully this helps a bit.


  • Thanks 1
Link to post
Share on other sites
Jimmy Stigsjoo

Ah right. 

When i first started with Vatsim, ALL Aircrafts was a the same type, regardless of which they actually used ( All displayed a White 737, even if they were flying something else

I know that i did Install a AI Package as per guides, so the issue must be in the settings as you described. Will look into that and try it. Thank you so much once again :)

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...