Jump to content

Aircraft Symbology problem (TopSky 2.2.1b11)


Elias Stassinos (1041728)
 Share

Recommended Posts

Elias Stassinos (1041728)

I have disabled ES symbology for the Aircraft as instructed int he manual.

The problem is that it seems that topsky doesn't draw the symbols as it should.

My current scope looks like this.

What am i missing?

image.png.b81b67e761a57d5de6df9cab85e22ba3.png

image.png.fc377212ee0b6585250aae43324c109e.png

Link to comment
Share on other sites

Juha Holopainen

Based on those images alone it could be anything really. The bottom one appears to display primary radar target symbols. If that's true, then the plugin does at least draw something on the screen. Why it's then not drawing the symbol in the top one, I don't know. If you have selected to display squawk standby targets, it may be that the aircraft didn't have its transponder on and if it was outside primary radar coverage, the plugin wouldn't then show any track symbol, but that's just a guess.

Link to comment
Share on other sites

Elias Stassinos (1041728)
4 hours ago, Juha Holopainen said:

Based on those images alone it could be anything really. The bottom one appears to display primary radar target symbols. If that's true, then the plugin does at least draw something on the screen. Why it's then not drawing the symbol in the top one, I don't know. If you have selected to display squawk standby targets, it may be that the aircraft didn't have its transponder on and if it was outside primary radar coverage, the plugin wouldn't then show any track symbol, but that's just a guess.

Thank you for the reply.

Do you have an image as to what the Topsky symbol would look like?

 

Link to comment
Share on other sites

Juha Holopainen

The symbols the plugin is set up to use can be checked by clicking the “View” button for the Symbols data file in the Plugin Status menu.

Link to comment
Share on other sites

Elias Stassinos (1041728)

So now its getting clearer...

I have "BAD DATA" so it means that something is wrong in the settings and that is the reason why they don't show up.

image.thumb.png.c5b455888d3a8e14e392c0e6086c52fc.png

And this is what i have in my TopSkySymbols.txt. Where is the mistake?

//Coasting track symbol
SYMBOL:RPSC
MOVETO -3 -3
LINETO 4 4
MOVETO 3 -3
LINETO -4 4
MOVETO 0 -4
LINETO 0 5
MOVETO -4 0
LINETO 5 0


//Radar position symbol for PSR tracks
SYMBOL:RPS1
MOVETO -3 -3
LINETO 3 -3
LINETO 3 3
LINETO -3 3
LINETO -3 -3
MOVETO -2 -2
LINETO 3 3
MOVETO 2 -2
LINETO -3 3

//Radar position symbol for SSR(A) tracks
SYMBOL:RPS2
MOVETO -3 -3
LINETO 3 -3
LINETO 3 3
LINETO -3 3
LINETO -3 -3
MOVETO -2 -2
LINETO 3 3
MOVETO 2 -2
LINETO -3 3

//Radar position symbol for SSR(A) tracks with ident
SYMBOL:RPS2I
MOVETO -3 -3
LINETO 3 -3
LINETO 3 3
LINETO -3 3
LINETO -3 -3
MOVETO -2 -2
LINETO 3 3
MOVETO 2 -2
LINETO -3 3

//Radar position symbol for PSR+SSR(A) tracks
SYMBOL:RPS3
SETPIXEL:0:0
MOVETO -3 -3
LINETO 3 -3
LINETO 3 3
LINETO -3 3
LINETO -3 -3
MOVETO -2 -2
LINETO 3 3
MOVETO 2 -2
LINETO -3 3


//Radar position symbol for PSR+SSR(A) tracks with ident
SYMBOL:RPS3I
SETPIXEL:0:0
SETPIXEL:0:0
MOVETO -3 -3
LINETO 3 -3
LINETO 3 3
LINETO -3 3
LINETO -3 -3
MOVETO -2 -2
LINETO 3 3
MOVETO 2 -2
LINETO -3 3

 

Edited by Elias Stassinos
Link to comment
Share on other sites

Elias Stassinos (1041728)

It was obvious all the time.....

The separator of the file is not space but : :((((

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...