Jump to content

[dev] Debugging own plugins with TopSky


Ilya Pyankov (1132631)
 Share

Recommended Posts

Ilya Pyankov (1132631)

Good day!

With release either Euroscope beta release (.27) or TopSky 2.3.1 I've noticed that it is completely impossible to debug other plugins due to extreme mouse lags when breakpoint is hit. Never noticed that before.

Only unloading of TopSky plugin resolves situation.

Tested on Visual Studio 2019 141/142 platform toolset.

For reproduction try to debug for example RDF Finder plugin with TopSky connected.

Is something changed or any other recommendations for solution?

Link to comment
Share on other sites

Bernardo Reis (1096507)

As far as I know, RDF plugin is not compatible with Topsky.

Topsky has it's own RDF on "Setup->RDF"

Link to comment
Share on other sites

Ilya Pyankov (1132631)
5 hours ago, Bernardo Reis said:

As far as I know, RDF plugin is not compatible with Topsky.

Topsky has it's own RDF on "Setup->RDF"

That's true but is not a reason.

Debugging of even empty plugin results in the same.

Link to comment
Share on other sites

Juha Holopainen

The easiest solution would be to unload the plugin then? If you need TopSky to be loaded while debugging another plugin, you can try to disable TopSky's mouse hook which is a likely candidate for the thing causing the lag. "System_UseMouseWheel=0" in the settings file should do it, as long as it's there on plugin startup.

Also, TopSky should be compatible with the RDF plugin as long as "RDF_Mode=-1" is set.

Edited by Juha Holopainen
Link to comment
Share on other sites

Ilya Pyankov (1132631)
17 hours ago, Juha Holopainen said:

The easiest solution would be to unload the plugin then? If you need TopSky to be loaded while debugging another plugin, you can try to disable TopSky's mouse hook which is a likely candidate for the thing causing the lag. "System_UseMouseWheel=0" in the settings file should do it, as long as it's there on plugin startup.

Also, TopSky should be compatible with the RDF plugin as long as "RDF_Mode=-1" is set.

Thank you very much. Disabling mouse hook resolved situation

Edited by Ilya Pyankov
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...