Jump to content

NOTAM area not being detected


Ricardo Sousa (1110850)
 Share

Recommended Posts

Ricardo Sousa (1110850)

Got two NOTAM areas that never get picked up, from what I read on the manual I suspect that it's due to the Notam text not having any "ACT" anywhere. If this is the issue, could the ACT part not be hardcoded?

 

//SNOWFALL
AREA:T:SNOWFALL
CATEGORY:NOTAM
ACTIVE:NOTAM:LPPC:SNOWFALL
LABEL:N040.05.00.000:W007.16.00.000:SFL290
////USERTEXT:SFL290
LIMITS:245:280
N041.18.00.000 W007.23.00.000
......
N041.18.00.000 W007.23.00.000

//NEVERLAND
AREA:T:NEVERLAND
CATEGORY:NOTAM
ACTIVE:NOTAM:LPPC:NEVERLAND
LABEL:N040.40.00.000:W006.56.00.000:SFL290
////USERTEXT:SFL290
LIMITS:245:280
N040.32.00.000 W007.45.00.000
.....
N040.32.00.000 W007.45.00.000

 

A1270/20 NOTAMN
Q) LPPC/QRALW/IV/NBO/W /245/280/4013N00716W030
A) LPPC B) 2005041345 C) 2005081200
D) 04 1345-1550, 05-08 1000-1200
E) AIRSPACE RESERVATION AREA SNOWFALL: 403200N 0074500W - 403157N 
0064722W - EXCLUDING SPANISH AIRSPACE - 395337N 0065359W - 395400N 
0074500W - 403200N 0074500W.
F) FL245 G) FL280

 

A1271/20 NOTAMN
Q) LPPC/QRALW/IV/NBO/W /245/280/4058N00705W041
A) LPPC B) 2005041345 C) 2005081200
D) 04 1345-1550, 05-08 1000-1200
E) AIRSPACE RESERVATION AREA NEVERLAND: 411800N 0072300W - 412248N 
0062333W - EXCLUDING SPANISH AIRSPACE - 403157N 0064722W - 403200N 
0074500W - 404350N 0074500W - 411800N 0072300W.
F) FL245 G) FL280

The notam text is always like this for these areas in particular, been like this for the past 4 or 5 years or however old they are

Link to comment
Share on other sites

Martin Loxbo (811805)

You can edit what text the plugin looks for when checking if an area is active. Add this line to TopSkySettings.txt:

HTTP_NOTAM_Area_Sched_Text= 

If you want the area to be activated without any specific keyword, simply put a blank space after the = sign. Then the plugin will activate the areas whenever it sees a NOTAM that matches the ACTIVE text.

The downside of this is that areas will activate any time the area is mentioned in a NOTAM, so you may see some "false" activations.

Link to comment
Share on other sites

Juha Holopainen

The default value for the mentioned setting has been (blank) for some time now. Earlier it was " ACT", can't remember in which version the change took place. Note that entering a blank space as the setting value will search for any NOTAM containing a blank space character in the text part, which would be almost any NOTAM, and the area-specific text defined in the data file. As written in the developer spreadsheet, the default value (blank) causes the code to look for NOTAMs containing the area-specific text and the NOTAM Q-code starting with "QR" (NOTAMs dealing with airspace restrictions) and ending with "CA" (activated). As the Q-codes in the NOTAMs you have end with "LW" (will take place), the code doesn't see them as area activation NOTAMs.

You could try Martin's suggestion and enter a space character as defining an area activation NOTAM, and see how many falsely activated areas that generates. Before taking a good look at what kind of NOTAMs are published worldwide ending with "LW", I'd rather not allow that as an area-activating code as the result may be a big increase of false activations.

Link to comment
Share on other sites

Maxim Tsygankov (1264756)

Hello @Juha Holopainen

We are trying to adapt TopSky for Moscow FIR, but have a problem with automatical restrictions areas activation.

Here is one example with UUR366, but we have the same issue with all areas at Moscow, which should be activated by NOTAM. 

Quote

AREA:T:UUR366
CATEGORY:UUR
LABEL:N054.26.30.000:E037.34.30.000:UUR366
ACTIVE:NOTAM:UUWV:UUR366
N054.25.00.000 E037.30.00.000
N054.26.30.000 E037.34.30.000
N054.24.30.000 E037.37.00.000
N054.22.00.000 E037.36.10.000
N054.21.00.000 E037.34.00.000
N054.25.00.000 E037.30.00.000

H3548/20 NOTAMN
Q) UUWV/QRRCA/IV/BO/W/000/999/5424N03734E003
A) UUWV B) 2005011800 C) 2006010300
D) DAILY 1800-0300
E) RESTRICTED AREA ACT: UUR366.
F) GND  G) 6500M AGL
CREATED: 24 Apr 2020 10:09:00 
SOURCE: UUUUYNYX

We have this NOTAM in TopSky's list, but area doesn't activate. If we set ACTIVE:1, it works. I tried to manually set HTTP_NOTAM_Area_Sched_Text=QRRCA, or just Q, or space - no result.

Hope you could help us!

Link to comment
Share on other sites

Juha Holopainen

@Ricardo Sousa, I've changed the list so that the next version will accept QR?LW as an area activation NOTAM type (? being any character). Some codes beginning with "QW" are actually already accepted in addition to QR?CA, the documentation fails to note that (they are QW?CA, QW?HJ, QW?HU and QW?LW). The documentation with the next version will have the correct list.

@Maxim Tsygankov, it's probably the period character throwing the code off (it doesn't accept "UUR366." to be the same as "UUR366"). The setting you refer to only looks at the text part (E) of the NOTAM, so it won't work with any Q-codes. The space-character entry would be a match as the E part of the NOTAM does contain space characters, but the default setting would work as well as the Q-code QRRCA is defined as an area activation type in the code.

Note that the current code does not handle metric levels in the NOTAMs correctly, so even if it did activate the area, you'd have to adjust the vertical limits (the code would set the upper limit at 6500 feet AMSL). The next version will attempt to handle also metric levels, and it will be possible to set a ground elevation value to the area definitions so AGL values will be corrected to AMSL (obviously with just one fixed value not following the actual terrain). I'll also make it accept a period character next to the area name. You can try if the activation works correctly using "ACTIVE:NOTAM:UUWV:UUR366." but the vertical limits will be wrong with numbers being always read as feet until the next plugin version.

  • Like 2
Link to comment
Share on other sites

Ricardo Sousa (1110850)
1 hour ago, Juha Holopainen said:

 

it's probably the period character throwing the code off (it doesn't accept "UUR366." to be the same as "UUR366").

Actually I might be going through this as well, the notam has

E) AIRSPACE RESERVATION AREA SNOWFALL: 

and I'm trying to match it with AREA SNOWFALL, but I suppose it doesn't match because of the ':' in the Notam. I tried with

ACTIVE:NOTAM:LPPC:AREA SNOWFALL:

but still nothing. or is this because of the Q code? I already have the HTTP_NOTAM_Area_Sched_Text= set with a blankspace

 

Edited by Ricardo Sousa
Link to comment
Share on other sites

Mark-Julius Pikat (1051954)
1 hour ago, Ricardo Sousa said:

Actually I might be going through this as well, the notam has

E) AIRSPACE RESERVATION AREA SNOWFALL: 

and I'm trying to match it with AREA SNOWFALL, but I suppose it doesn't match because of the ':' in the Notam. I tried with

ACTIVE:NOTAM:LPPC:AREA SNOWFALL:

but still nothing. or is this because of the Q code? I already have the HTTP_NOTAM_Area_Sched_Text= set with a blankspace

 

Try to remove the column ":" from the area definition, because it can still find the "AREA SNOWFALL" inside the NOTAM

spacer.png

Mark-Julius Pikat
Head of VACC Estonia
mark-julius.pikat [at] estvacc.org

Link to comment
Share on other sites

Maxim Tsygankov (1264756)

Hi Juha,

Thanks for answer.

I have tried to do make all possible variants with another area (UUR417), including full E) sting. Unfortunately, no result.

Quote

ACTIVE:NOTAM:UUWV:UUR417
ACTIVE:NOTAM:UUWV:UUR417.
ACTIVE:NOTAM:UUWV: UUR417.
ACTIVE:NOTAM:UUWV:ACT: UUR417.
ACTIVE:NOTAM:UUWV:RESTRICTED AREA ACT: UUR417.
ACTIVE:NOTAM:UUWV:E) RESTRICTED AREA ACT: UUR417.

H5890/20 NOTAMN
Q) UUWV/QRRCA/IV/BO/W/000/100/5601N03847E009
A) UUWV B) 2005120400 C) 2005301400
D) 12 14 15 18-22 25-29 0400-2100, 13 1100-2100, 16 23 30 0400-1400
E) RESTRICTED AREA ACT: UUR417.
F) GND  G) FL100

Maybe plugin can't understand any special symbols in E string, like ":" or "." ?

I take NOTAM from Minsk, and it works with plain text in E string.

Quote
O0867/20 NOTAMN
Q) UMMV/QRDCA/IV/BO /W /000/023/5433N02617E001
A) UMMV B) 2005110600 C) 2005162359
D) DAILY 0600-2359
E) DANGER AREA UMD235 ACTIVATED
F) GND G) 2300FT AMSL

 

Link to comment
Share on other sites

Ricardo Sousa (1110850)
1 hour ago, Mark-Julius Pikat said:

Try to remove the column ":" from the area definition, because it can still find the "AREA SNOWFALL" inside the NOTAM

tried it, nothing

Link to comment
Share on other sites

Juha Holopainen

The next plugin version will be able to handle the colon character (it'll just convert any period, comma, colon or newline characters into spaces when going through the E field of the NOTAM). This should fix all these issues. The conversions are necessary as the plugin actually searches for " defined text ", i.e. spaces on both sides of the text. This is to avoid activating for example area R1 when a NOTAM contains "R11".

There are some more special characters that can appear in the NOTAM text, but I'll keep the conversion list based on actually observed needs in order to keep unintentional activations as low as possible.

  • Like 2
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...